杭电1008(坑)

Author Avatar
Peipei Wong 3月 19, 2014
  • 在其它设备中阅读本文章

注意格式

Problem Description
Tomorrow is contest day, Are you all ready?
We have been training for 45 days, and all guys must be tired.But , you are so lucky comparing with many excellent boys who have no chance to attend the Province-Final.
Now, your task is relaxing yourself and making the last practice. I guess that at least there are 2 problems which are easier than this problem.
what does this problem describe?
Give you a positive integer, please split it to some prime numbers, and you can got it through sample input and sample output.
Input
Input file contains multiple test case, each case consists of a positive integer n(1<n<65536), one per line. a negative terminates the input, and it should not to be processed.

Output
For each test case you should output its factor as sample output (prime factor must come forth ascending ), there is a blank line between outputs.

Sample Input

60
12
-1

Sample Output

Case 1.
2 2 3 1 5 1

Case 2.
2 2 3 1

#include<stdio.h>
int main()
{
    int n,i,j=1;
    while(scanf("%d",&n)&&n>0)
    {
        int a[65537]={0};
  if(j>1)
   printf("\n");
        printf("Case %d.\n",j);
        j=j+1;
        for(i=2;n!=1;)
        {
            if(n%i==0)
            {
                a[i]=a[i]+1;
                n=n/i;
            }
            else i++;
        }
        int p=i;
        for(i=2;i<=p;i++)
        {
            if(a[i]!=0)
            {
                printf("%d %d ",i,a[i]);
            }
        }
        printf("\n");
    }
    return 0;
}