HDU1004超级楼梯
Problem Description
有一楼梯共M级,刚开始时你在第一级,若每次只能跨上一级或二级,要走上第M级,共有多少种走法?
Input
输入数据首先包含一个整数N,表示测试实例的个数,然后是N行数据,每行包含一个整数M(1<=M<=40),表示楼梯的级数。
Output
对于每个测试实例,请输出不同走法的数量
Sample Input
2
2
3
Sample Output
12
#include<iostream>
#include <stdio.h>
using namespace std;
int main()
{
int n;
int fun(int n);
scanf("%d",&n);
int i,k;
for(i=0;i<n;i++)
{
scanf("%d",&k);
long long int m[50]={0,0,1,2};
if(k<=3)
{
m[k]=k-1;
cout<<m[k]<<endl;
}
else
{
for(int i=4;i<=k;i++)
{
m[4]=m[3]+m[2];
m[2]=m[3];
m[3]=m[4];
}
cout<<m[4]<<endl;
}
}
return 0;
}