杭电1007FatMouse' Trade
Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i] a% pounds of JavaBeans if he pays F[i] a% pounds of
cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed
by two -1’s. All integers are not greater than 1000.
Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
Sample Output
13.33331.500
#include<iostream>
#include<stdio.h>
#include<stdlib.h>
using namespace std;
struct num1
{
double a;
double b;
double c;
}num[10001];
int Compare(const void *a, const void *b)
{
struct num1 *p,*q;
p=(num1 *)a;
q=(num1 *)b;
if(p->c<q->c)
return 1;
else if(p->c>q->c)
return -1;
else return 0;
}
int main()
{
int n,i,m;
while(scanf("%d%d",&n,&m))
{
if(m==-1&&n==-1)
break;
double sum=0.0;
for(i=0;i<m;i++)
{
scanf("%lf%lf",&num[i].a,&num[i].b);
num[i].c=(num[i].a)/(num[i].b);
}
qsort(num,m,sizeof(num[0]),Compare);
for(i=0;i<m&&n>0;i++)
{
if(n<num[i].b)
num[i].a=num[i].c*n;
sum=sum+num[i].a;
n=(double)(n-num[i].b);
}
printf("%.3lf\n",sum);
}
return 0;
}
//数组排序太慢,注意compare的排序。